Android 14 April security patch rolling out for Pixel devices

Android 14 April security patch rolling out for Pixel devices

Disclaimer: Content Source The content on this website is for informational purposes only. We would like to clarify that the information provided here is sourced from various publicly available outlets on the internet. None of the content on this website is authored, reviewed, or endorsed by our team.



Google has started the rollout of its critical April 2024 security patch for Pixel phones. The update, announced in a Pixel community post, addresses numerous vulnerabilities and potential exploits. If you own a compatible Pixel device, you might have it waiting already, but wide availability will take a few weeks.The April 2024 update targets the Pixel 5a 5G and all newer Pixel models. Look for build number AP1A.240405.002 (or the .A1 variant for the Pixel Fold). Carrier and regional factors may influence when you see the update available on your device.

Google’s release notes highlight a substantial list of fixes. The update addresses eight general Android 14 vulnerabilities (dated April 1st) and an additional 20 dated April 5th. Severity levels range from high to critical. Below are the most notable ones listed in the changelog:

  

Biometrics

  • Fix for issue causing black screen to appear when unlocking screen in certain conditions (Pixel 5a 5G)

Camera

  • Fix for camera stability under certain conditions when switching between different zooms (Pixel 6, Pixel 6 Pro, Pixel 6a, Pixel 7, Pixel 7 Pro, Pixel 7a, Pixel 8, Pixel 8 Pro, Pixel Fold)
  • Fix for issue with black halo artifacts appearing under certain conditions in the viewfinder upon transitioning from photo to video mode at 1x zoom (Pixel 8 and Pixel 8 Pro)
  • Fix for issue where users are unable to re-expose image after tapping anywhere on the viewfinder (Pixel 8 and Pixel 8 Pro)
See also  T-Mobile confirms new monthly fee for April 25: here's how you can avoid it
  

More importantly, the company warns that two Pixel-specific flaws (CVE-2024-29745 and CVE-2024-29748), affecting the bootloader and firmware, “may be under limited, targeted exploitation.” While details are scarce, this underscores the urgency of updating your device.



Source link

Comments

No comments yet. Why don’t you start the discussion?

Leave a Reply

Your email address will not be published. Required fields are marked *